Page 2 of 2 FirstFirst 12
Results 26 to 30 of 30

Thread: Swiftech Pump leaking

  1. #26
    Xtreme Member
    Join Date
    Feb 2003
    Location
    Orlando, FL
    Posts
    256
    Turbo - are you using mobo monitor?
    Do you have any pics of your set up?

  2. #27
    Registered User
    Join Date
    Jan 2003
    Location
    canada
    Posts
    8
    And Swiftec said they made this pump because the Eheim was not reliable what a bunch of d*ck heads
    There are many stories like that about those pumps
    Last edited by roblae; 06-11-2003 at 03:09 PM.

    AMD AthlonXP 2400+@14X166
    Asus A7V333
    ATI Radeon9700pro
    Performance Cooled by D-Tek & Danger Den

  3. #28
    Xtremely slow runner
    Join Date
    Nov 2002
    Posts
    4,900
    I think their working on a new version because of the many fails of the actual one. Couldn't they test them before selling them?
    The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

    Av by Frisch This is not a Lime tree

  4. #29
    Xtreme Member
    Join Date
    Nov 2002
    Location
    SoCal
    Posts
    190
    Out of 3 Swifty pumps, I've had 2 die. Symptoms were clattering noises after ~ 2 weeks, then total death. One of the pumps leaked from under the chassis (not at the fittings). Looked similar to the pic you posted. Swiftech has been good with RMAs and replaced them. However, my confidence in these pumps is gone, so I got several Eheim 1250's to replace them.

  5. #30
    Xtreme Recruit
    Join Date
    Nov 2002
    Location
    Oxford, AL
    Posts
    97
    *note to self, avoid swiftech pumps....*
    damn, i hate havin to learn from y'alls mistakes, but i s'pose it'll save me some $ and time down the road....
    Albatron PX845PE IIS
    P4 2.4b stock volts, oc'ed to 2.6 retail hsf
    2 x 256mb ddr333(Kingston), 1 x 256mb ddr333(Samsung)
    60 and 120 gig WD 7200rpm 2mb cache drives...
    Sony 12x dvd
    NEC 8x4x12 dvd+-rw
    Gainward GF4 Ti4200 PowerPack Ultra/650 XP VIVO/DVI with 128MB RAM
    Soung Blaster Audigy MP3+
    WinXP Pro

Page 2 of 2 FirstFirst 12

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •