Results 1 to 2 of 2

Thread: Epyc and XenServer 7.X need help (Error AMD-V)

  1. #1
    Xtreme Cruncher
    Join Date
    Apr 2008

    Epyc and XenServer 7.X need help (Error AMD-V)

    When running XenServer 7.3-7.5 On AMD EPYC (HPE DL385 Gen10) I cannot boot MxGPU setup using S7150x2 cards
    Now, yes, HCL does not show DL385 Gen supported, but shows EPYC supported
    I did the same setup on my ThreadRipper 1950x and have same issues

    When I run xl dmesg I see the following

    (XEN) AMD-Vi: Error initialization
    (XEN) I/O virtualisation disabled

    Yes BIOS on both HPE server and my Test rig have all AMD-V features enabled
    Anyone no why Xen is not able to use IOMMU on AMD Epyc or Ryzen?
    AMD Ryzen 9 3900X
    GigaByte X570 AORUS LITE
    Trident-Z 3200 CL14 16GB
    AMD Radeon VII
    AMD Ryzen ThreadRipper 2950x
    Asus Prime X399-A
    GSkill Flare-X 3200mhz, CAS14, 64GB
    AMD RX 5700 XT

  2. #2
    Xtreme Addict
    Join Date
    Sep 2010
    US, MI
    This isn't going to be of any help.
    But I tested it with my 1090t way back when, with an asus ch4f, supposedly having full support...
    I found there was no actual support bios wise at all.
    It was a farce.

    My current board and cpu, the 4930k, and the r4be, didn't have support for it either even though asus had advertised it.
    It was only when a half dozen or so went to there forums and complained about it, then they put out a bios that fixed it.

    Amd is the cheapo platform, no offence intended.
    What you tend to get is stuff advertised but not actually tested or working.
    A 1/4 of the boards with the ryzen couldn't even boot linux at the beginning, and not because of lack of kernel support, but because of screwed up resource mappings in the bios.

    If the asus x399 is what you have, you need to get to there forums with a quickness and complain about it before a year or 2 is up.
    These days you're lucky to get more then a year of support for your board, bios wise.
    So if it's borked, you gotta get on it, other it will not get fixed..

    One other thing you can check is to see if your bios options are backwards.
    Ie, enabled actually means disabled, and vice versa.
    One of the last dfi boards was like that when setting up for a buddy.
    Couldn't even boot the windows installer because one of the options was backwards, it was an easy fix but stupid.

    I really do suspect it's your bios, and asus's awesome quality support lol :\.
    I do think you're gonna have to track down the rog forums and complain, I think they're still up, because I got a stupid email from them a little while back about policies term updates.
    And good luck man.

    Oh btw, I don't know if you know this, but on amd these days you might have to disable certain pstates to prevent it from crashing on ramdom in linux/bsd.
    It effects the epyc's too.
    You might have luck with that or not, it's just a heads up.
    Last edited by NEOAethyr; 07-28-2018 at 04:51 AM.

    CPU: Intel Core i7-4930k [3332B054]
    CPU Heatsink: NZXT Kraken X60
    Mobo: ASUS Rampage IV Black Edition (0507 BIOS)
    MEM: 4x 4gig G.Skill [F3-2400C9Q-16GTXD] (Dual Sidded Samsung of Some Sorts)
    PSU: Antec HCP-850 Platinum
    VGA: nVidia Grid VGX K2 (WIP with 2x 680 lightnings)
    Monitor: ASUS VG278HE & 3DVision2 Kit
    Drives: 2x WD Red 2TB Drives [WDBMMA0020HNC-NRSN] (RAID 0), Corsair Force Series 3 CSSD-F60GB3A-BK 60GB SATA3 SSD, Pioneer BDR-2208 Blue Ray Burner
    Case: Rosewill Blackhawk Ultra
    OS's: Windows 2003 Enterprise x86 SP2-R2 VLM, Windows 7 Standard Embedded x86 SP1 EVL (128GB Patched), Windows 7 Standard Embedded x64 SP1 EVL
    Mouse: Using generic mouse for now...
    Arm:Samsung Galaxy S IV i9500 Octo-Core Quad Band 16gb Unlocked and 2x 64gig sd cards

    Sig is slightly out of date, I'll update it later ^^



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts