Results 1 to 2 of 2

Thread: Cleaning new Alphacool radiators and Primochill SysPrep

  1. #1
    Registered User
    Join Date
    Jan 2010
    Location
    Houston, TX
    Posts
    67

    Cleaning new Alphacool radiators and Primochill SysPrep

    I'm putting together a couple of new loops using the full copper Alphacool Nexxos radiators and I've read in a few forums that Alphacool radiators need alot of cleaning prior to use. Most of these posts are 3-4 years old however, and I'm wondering if Alphacool has improved on their cleaning process of their new lines of Radiators. In the past I've used XSPC Rads and have only rinsed them with warm distilled water prior to use, and haven't had any issues. It's also worth noting these rads look pretty clean, and after a cold water rinse, I've seen no debris.

    I also have a couple of bottles of Primochill SysPrep, which is recommended to run a couple of days and is supposed to "clean" out your entire loop. In fact they say you can leave it in indefinitely, but recommend draining after running for 48 hours and replacing with coolant of choice.

    Anyone have any experience with these new rads or with the Sysprep? Any thoughts would be welcome.
    HAF 932-ASUS Rampage Formula III-i7 980x-12G G-Skill Sniper 1600 C9-GTX970 4g SLI-Corsair AX1200i PSU-Dual Loop WC
    Thermaltake W200-Rampage V Edition 10-i7-6850k-G-Skill TridentZ F4-3200C14Q-GTX1080Ti Strix SLI-Corsair AX1500i-Dual Loop WC

  2. #2
    Registered User
    Join Date
    Jan 2008
    Posts
    3
    Make sure to rinse SysPrep prior to adding coolant. Otherwise you will get micro bubbles in your water.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •