Results 1 to 2 of 2

Thread: Creative X-Fi Soundcards and Windows 10 Fall Creators Update 1709 = Complete Disaster

  1. #1
    Xtreme XIP
    Join Date
    Jun 2007
    Location
    Puerto Rico
    Posts
    1,538

    Angry Creative X-Fi Soundcards and Windows 10 Fall Creators Update 1709 = Complete Disaster

    Hi i need some help. I am also suffering this bug that when installing Windows 10 Fall Creators Update 1709 + Creative X-Fi Titanium sound card it goes into oblivion of black screens crash , bsod and system is unresponsive. When installing a fresh / new installation from my usb thumb drive of the Windows 10 Fall Creators Update 1709 i get some weird black screen crash and system becomes unresponsive after installing the latest drivers from the creative website or Daniel K package for my Creative X-Fi Titanium pci-express sound card. After installation of the fresh OS i noticed it detects my X-Fi Titanium as a high definition audio device under device manager sound and not as an X-Fi sound card as previously on Windows 10 Creators Update 1703.

    With Windows 10 Creators Update 1703 everything runs perfectly without a single problem with my Creative X-Fi Titanium , the problem started with the Windows 10 Fall Creators Update 1709 , so the culprit of the problems is the Creative drivers and W10 Fall CU 1709 , as something has change in the way it detects audio devices and the drivers.

    I have wrote to microsoft support for help and on the feedback hub from within windows but without luck so far :/ , this is frustrating as everything was working so good and great before the Windows 10 Fall Creators Update 1709. I have search the whole web for a week for a fix but i have not been unable to find one. As some other people who have posted here on this thread i also am running an AMD AM4 x370 / Ryzen set up.

    If someone has found a fix for this huge problem please reply to me if possible so that i can use my Creative X-Fi soundcard again ( I'm Using Realtek Onboard sound and it is horrible , me do not like it ). Please help.

    Hardware Configuration:
    --------------------------
    Asus Crosshair VI Hero x370 / AMD Ryzen 1700x / G.Skill 2x8GB DDR4 3200Mhz Cas 14 / Nvidia GTX 1080Ti / Crucial MX300 1TB SSD + WD Green 2TB HD / eVGA Supernova G3 1300w psu / and of course Creative X-Fi Titanium pci-express sound card.

    Here is a link for this same problem reported at Microsoft support and on Creative Support website:

    https://answers.microsoft.com/en-us/...c-6bcf7ada849a

    http://forums.creative.com/showthread.php?t=742065

    Kind Regards: Chispy
    Last edited by chispy; 11-14-2017 at 08:08 AM.

  2. #2
    Xtreme Addict
    Join Date
    Sep 2010
    Location
    US, MI
    Posts
    1,678
    You need to post the full device id from the device manager or something (you may have to unlock that setting...)
    I'm not in windows and I barely use it anymore except for random things sparingly , I can't remember how to get the extra tabs in the device manager.
    In the last tab though there will be a drop down box you can scroll through and one of them will be the full id of the device.

    The device id is important, if it failed in some way it'll install the wrong driver.
    They can be caused by the card not inserted correctly, which can happen if the mobo isn't lined up just right with the case.
    Or if the slots or connectors are dirty.

    Btw, ac97 and hd audio devices are really work the same pretty much.
    You can install an intel hda driver for a realtek, and vise versa, sometimes anyways.
    Not that I recommend that..
    It's possible that MS just said screw it, and decide that the x-fi stuff should be treated as all the rest of the audio chips.
    One a bunk driver is installed, it'll be called something like oem*.inf.
    I can't remember the location of those.
    You can find it using a search using admin.
    If you find your id in a generic driver inf like that, either cut that inf and paste it somewhere else, or del it.
    Then it won't auto install it on next reboot.
    From there you can install the correct driver.

    Can you boot into safe mode with it?
    This could be a slightly tricky one to fix, but it should be fixable if it's not something in the os it's self causing the issue.
    Sounds like a pain in the butt.

    I have a few more suggestions.
    Try a diff pci-e slot.
    This could be a irq or other i/o / dma resource prob.
    Lemme look up some of my stuff real quickly...
    Ok, in win xp/2003 it was in boot.ini "/PCILOCK".

    https://msdn.microsoft.com/en-us/lib...(v=vs.85).aspx
    I think the cmd may go: (I have not done this since the nf2, where I had modded the bios to setup everything for quadro stability past 266mhz 1:1...)
    bcdedit /set {current} UseFirmwarePCISettings true
    It could be yes instead of true.
    That should make windows use the setup the actual bios set, instead of redoing it for it's self.
    This could fix probs, or it could cause them.
    I don't know if you've used dos in the past, but a hardware conflict isn't always an easy thing to deal with sometimes.

    This all depends on if it's sharing a resource with something that it can't be shared with.
    Most of the time these days it's ok'ish to do so, not optimal, but ok.
    In the device manager you can sort by resource type and find out, I'de start at the irq's.
    Not that this is the actual prob though, but a small chance it could be.

    Anyways I hope you get it working dude, that's sucks .
    Let us know if you figure anything out.

    Some random spam I use before i go on to tweaking and gutting, not of any use, but it'll get you an idea of how to manage the boot loader, getting fs and reg permissions and so on.

    Edit: I have to warn you, I'm reading through this batch I posted below, and the NX bit setting, DO NOT disable it like I was in win7, in win10 it'll bsod and you'll lose the os.
    This is only for ref really...

    Code:
    @ECHO OFF
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    :: BCDEdit
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    :: on 32bit I need to add the other 2 options...
    
    :: this works, no more need for bcdedit...
    :: bcdedit /default {current}
    :: bcdedit /displayorder {current} {5be90490-9593-11e5-88b0-cab7c1e50fdf}
    :: bcdedit /bootsequence {current} {5be90490-9593-11e5-88b0-cab7c1e50fdf}
    :: bcdedit /set {current} description "Windows 7 SP1 x64 VLMF - Tweaked"
    :: bcdedit /set {5be90490-9593-11e5-88b0-cab7c1e50fdf} description "Windows 7 SP1 x64 VLMF - Stock"
    :: bcdedit /timeout 30
    
    :: bcdedit /bootsequence {ID} {ID} {ID}
    :: bcdedit /v
    :: bcdedit /set ID description "The new description"
    
    
    
    
    :: enable avx
    bcdedit /set {current} xsavedisable 0
    
    :: Try to disable driver enforement...
    bcdedit /set {current} loadoptions DDISABLE_INTEGRITY_CHECKS
    bcdedit /set {current} nointegritychecks yes
    
    :: clock
    bcdedit /set {current} useplatformclock true
    
    :: no exe bit always off
    bcdedit /set {current} nx AlwaysOff
    
    :: pae enable
    bcdedit /set {current} pae ForceEnable
    
    :: Win8.., disable dynamic tick
    bcdedit /set {current} disabledynamictick yes
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    :: Copy Section
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    :Copy_Section
    
    ::::::::::::::::::::
    :: Registry Tools
    ::::::::::::::::::::
    
    COPY /Y ".\Files\Generic\Windows\System32\subinacl.exe" "%SystemDrive%\Windows\System32\subinacl.exe"
    
    :: need to check if I'm using x64 or x86 here...
    :: 64bit ver is needed for 64 because some keys are stubborn
    ::COPY /Y ".\Files\Generic\Windows\System32\SetACL.exe" "%SystemDrive%\Windows\System32\SetACL.exe"
    COPY /Y ".\Files\Generic\Windows\System32\SetACLx64.exe" "%SystemDrive%\Windows\System32\SetACL.exe"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: NTVDM Subsystem
    ::::::::::::::::::::
    
    COPY /Y ".\Files\Generic\Windows\System32\autoexec.nt" "%SystemDrive%\Windows\System32\autoexec.nt"
    COPY /Y ".\Files\Generic\Windows\System32\config.nt" "%SystemDrive%\Windows\System32\config.nt"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Block Servers File
    ::::::::::::::::::::
    
    COPY /Y ".\Files\Generic\Windows\System32\drivers\etc\hosts" "%SystemDrive%\Windows\System32\drivers\etc\hosts"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Disable Flash Player Logging
    ::::::::::::::::::::
    
    ::mkdir is needed right now otherwise it won't copy the file into a non-existing dir
    mkdir "%SystemDrive%\Windows\System32\macromed\flash"
    COPY /Y ".\Files\Generic\Windows\System32\macromed\flash\mms.cfg" "%SystemDrive%\Windows\System32\macromed\flash\mms.cfg"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Other Unsorted
    ::::::::::::::::::::
    
    COPY /Y ".\Files\Generic\Windows\System32\mscomctl.ocx" "%SystemDrive%\Windows\System32\mscomctl.ocx"
    COPY /Y ".\Files\Generic\Windows\System32\WNASPI32.DLL" "%SystemDrive%\Windows\System32\WNASPI32.DLL"
    
    regsvr32 /S "%SystemDrive%\Windows\System32\mscomctl.ocx"
    regsvr32 /S "%SystemDrive%\Windows\System32\WNASPI32.DLL"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Generic Extras
    ::::::::::::::::::::
    
    COPY /Y ".\Files\Generic\Windows\System32\dxcpl.exe" "%SystemDrive%\Windows\System32\dxcpl.exe"
    COPY /Y ".\Files\Generic\Windows\System32\mfc71.dll" "%SystemDrive%\Windows\System32\mfc71.dll"
    COPY /Y ".\Files\Generic\Windows\System32\mfc71u.dll" "%SystemDrive%\Windows\System32\mfc71u.dll"
    COPY /Y ".\Files\Generic\Windows\System32\Msvbvm50.dll" "%SystemDrive%\Windows\System32\Msvbvm50.dll"
    COPY /Y ".\Files\Generic\Windows\System32\msvci70.dll" "%SystemDrive%\Windows\System32\msvci70.dll"
    COPY /Y ".\Files\Generic\Windows\System32\msvcp71.dll" "%SystemDrive%\Windows\System32\msvcp71.dll"
    COPY /Y ".\Files\Generic\Windows\System32\msvcr70.dll" "%SystemDrive%\Windows\System32\msvcr70.dll"
    COPY /Y ".\Files\Generic\Windows\System32\msvcr71.dll" "%SystemDrive%\Windows\System32\msvcr71.dll"
    COPY /Y ".\Files\Generic\Windows\System32\pskill.exe" "%SystemDrive%\Windows\System32\pskill.exe"
    COPY /Y ".\Files\Generic\Windows\System32\tlst-mod.exe" "%SystemDrive%\Windows\System32\tlst-mod.exe"
    
    COPY /Y ".\Files\Generic\Windows\System32\choice.com" "%SystemDrive%\Windows\System32\choice.com"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    :: Take Ownership and Permissions of Registry and System Files
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    :Take_Ownership_and_Permissions
    
    ::::::::::::::::::::
    :: System Files
    ::::::::::::::::::::
    
    :: Can't set Ownership and Acl's at the same time otherwise it screws up Ownerships
    :: ok, not working for some files though like psxss.exe...
    SetACL -on %SystemDrive%\ -ot file -actn setowner -ownr "n:Administrators" -rec yes
    SetACL -on %SystemDrive%\ -ot file -actn ace -ace "n:Administrators;p:full" -rec yes
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Registry
    ::::::::::::::::::::
    
    :::: Defaults, win7 emb std sp1 x86
    
    ::HKEY_CLASSES_ROOT
    ::CREATOR OWNER		Full
    ::SYSTEM		Full
    ::Administrators	Full
    ::Users			Read
    
    ::HKEY_CURRENT_USER
    ::RESTRICTED		Read
    ::SYSTEM		Full
    ::Administrator		Full
    ::Administrators	Full
    
    ::HKEY_LOCAL_MACHINE
    ::Everyone		Read
    ::RESTRICTED		Read
    ::SYSTEM		Full
    ::Administrators	Full
    
    ::HKEY_USERS
    ::Everyone		Read
    ::RESTRICTED		Read
    ::SYSTEM		Full
    ::Administrators	Full
    
    ::::
    
    :: Don't set ownership and acl's at the same time, it screws up on files and it screws up on the reg
    
    :: :banana::banana::banana::banana:s up on this, Removes Users, adds Restricted, using subinacl as a cheap fix
    SetACL -on HKEY_CLASSES_ROOT -ot reg -actn setowner -ownr "n:Administrators" -rec yes
    SetACL -on HKEY_CLASSES_ROOT -ot reg -actn ace -ace "n:Administrators;p:full" -actn ace -ace "n:Users;p:read" -rec yes
    subinacl /subkeyreg HKEY_CLASSES_ROOT /revoke=Restricted
    
    SetACL -on HKEY_CURRENT_USER -ot reg -actn setowner -ownr "n:Administrators" -rec yes
    SetACL -on HKEY_CURRENT_USER -ot reg -actn ace -ace "n:Administrators;p:full" -rec yes
    
    SetACL -on HKEY_LOCAL_MACHINE -ot reg -actn setowner -ownr "n:Administrators" -rec yes
    SetACL -on HKEY_LOCAL_MACHINE -ot reg -actn ace -ace "n:Administrators;p:full" -rec yes
    
    SetACL -on HKEY_USERS -ot reg -actn setowner -ownr "n:Administrators" -rec yes
    SetACL -on HKEY_USERS -ot reg -actn ace -ace "n:Administrators;p:full" -rec yes
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    :: Command Section
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    :Command_Section
    
    ::::::::::::::::::::
    :: Delete NTFS USN Journals
    ::::::::::::::::::::
    
    fsutil usn deletejournal /d c:
    fsutil usn deletejournal /d d:
    fsutil usn deletejournal /d e:
    fsutil usn deletejournal /d f:
    fsutil usn deletejournal /d g:
    fsutil usn deletejournal /d h:
    fsutil usn deletejournal /d i:
    fsutil usn deletejournal /d j:
    fsutil usn deletejournal /d k:
    fsutil usn deletejournal /d l:
    fsutil usn deletejournal /d m:
    fsutil usn deletejournal /d n:
    fsutil usn deletejournal /d o:
    fsutil usn deletejournal /d p:
    fsutil usn deletejournal /d q:
    fsutil usn deletejournal /d r:
    fsutil usn deletejournal /d s:
    fsutil usn deletejournal /d t:
    fsutil usn deletejournal /d u:
    fsutil usn deletejournal /d v:
    fsutil usn deletejournal /d w:
    fsutil usn deletejournal /d x:
    fsutil usn deletejournal /d y:
    fsutil usn deletejournal /d z:
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Disk Performance Counters
    ::::::::::::::::::::
    
    :: Disable
    DISKPERF -N
    
    :: Enable
    ::DISKPERF -Y
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Disk Self Healing
    ::::::::::::::::::::
    
    :: Disable
    fsutil repair set c: 0
    fsutil repair set d: 0
    fsutil repair set e: 0
    fsutil repair set f: 0
    fsutil repair set g: 0
    fsutil repair set h: 0
    fsutil repair set i: 0
    fsutil repair set j: 0
    fsutil repair set k: 0
    fsutil repair set l: 0
    fsutil repair set m: 0
    fsutil repair set n: 0
    fsutil repair set o: 0
    fsutil repair set p: 0
    fsutil repair set q: 0
    fsutil repair set r: 0
    fsutil repair set s: 0
    fsutil repair set t: 0
    fsutil repair set u: 0
    fsutil repair set v: 0
    fsutil repair set w: 0
    fsutil repair set x: 0
    fsutil repair set y: 0
    fsutil repair set z: 0
    
    :: Enable
    ::fsutil repair set c: 1
    ::fsutil repair set d: 1
    ::fsutil repair set e: 1
    ::fsutil repair set f: 1
    ::fsutil repair set g: 1
    ::fsutil repair set h: 1
    ::fsutil repair set i: 1
    ::fsutil repair set j: 1
    ::fsutil repair set k: 1
    ::fsutil repair set l: 1
    ::fsutil repair set m: 1
    ::fsutil repair set n: 1
    ::fsutil repair set o: 1
    ::fsutil repair set p: 1
    ::fsutil repair set q: 1
    ::fsutil repair set r: 1
    ::fsutil repair set s: 1
    ::fsutil repair set t: 1
    ::fsutil repair set u: 1
    ::fsutil repair set v: 1
    ::fsutil repair set w: 1
    ::fsutil repair set x: 1
    ::fsutil repair set y: 1
    ::fsutil repair set z: 1
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Hibernation
    ::::::::::::::::::::
    
    :: Disable
    POWERCFG /H OFF
    
    :: Enable
    ::POWERCFG /H ON
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Network Autotuning
    ::::::::::::::::::::
    
    :: Disable
    netsh interface tcp set global autotuninglevel=disabled
    
    :: Enable
    ::netsh interface tcp set global autotuninglevel=normal
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: Network Teredo Tunneling
    ::::::::::::::::::::
    
    :: Disable
    netsh interface teredo set state disabled
    
    :: Enable
    ::netsh interface teredo set state enabled
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::
    :: DHTML Data Bindings
    ::::::::::::::::::::
    
    regsvr32 /U /S "%SystemDrive%\Program Files\Common Files\System\Ole DB\OLEDB32.DLL"
    DEL "%SystemDrive%\Program Files\Common Files\System\Ole DB\OLEDB32.DLL"
    DEL "%SystemDrive%\Windows\System32\dllcache\OLEDB32.DLL"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    :: Delete Section
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    
    :Delete_Section
    
    ::::::::::::::::::::
    :: Other
    ::::::::::::::::::::
    
    :: Doesn't exist by default but can cause problems if it exists
    :: needs redoing probably...
    DEL "%SystemDrive%\Windows\System32\spool\drivers\color\CalibratedDisplayProfile*.*"
    
    :: Comes with IE8 for the lang bar, annoying
    DEL "%SystemDrive%\Windows\System32\ctfmon.exe"
    
    ::::::::::::::::::::
    
    ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
    Last edited by NEOAethyr; 11-16-2017 at 02:11 AM.


    CPU: Intel Core i7-4930k [3332B054]
    CPU Heatsink: NZXT Kraken X60
    Mobo: ASUS Rampage IV Black Edition (0507 BIOS)
    MEM: 4x 4gig G.Skill [F3-2400C9Q-16GTXD] (Dual Sidded Samsung of Some Sorts)
    PSU: Antec HCP-850 Platinum
    VGA: nVidia Grid VGX K2 (WIP with 2x 680 lightnings)
    Monitor: ASUS VG278HE & 3DVision2 Kit
    Drives: 2x WD Red 2TB Drives [WDBMMA0020HNC-NRSN] (RAID 0), Corsair Force Series 3 CSSD-F60GB3A-BK 60GB SATA3 SSD, Pioneer BDR-2208 Blue Ray Burner
    Case: Rosewill Blackhawk Ultra
    OS's: Windows 2003 Enterprise x86 SP2-R2 VLM, Windows 7 Standard Embedded x86 SP1 EVL (128GB Patched), Windows 7 Standard Embedded x64 SP1 EVL
    Mouse: Using generic mouse for now...
    Arm:Samsung Galaxy S IV i9500 Octo-Core Quad Band 16gb Unlocked and 2x 64gig sd cards
    777

    Sig is slightly out of date, I'll update it later ^^


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •