I hope someone out there might have some insight to this very perplexing problem. I have had a Win 7 Pro machine (which was in a RAID 0 config using two Mushkin Reactor SSDs, 512GB each) which I updated to Win 10 sometime in Dec 2015. Not a single problem with the upgrade! Yea. Right after the Anniversary Update (which was early August), I noticed several wonky things happening like Blue screens saying things like CRITICAL_PROCESS_DIED and others which were very frustrating. I rolled back the AU and from that point every so often, I would get BSODs with a variety of code errors. I used Windows Tweaking AIO tool to try to fix things, but it just didn't seem quite right. I use this machine mostly for testing and gaming, so the loss of data wasn't super critical to me, other than a few games (which I back-up often). I decided it was time to do a clean bare-metal install, but I ran into a brick wall. After using MCT to get Windows 10 Pro 64bit on a USB flash drive, and resetting the RAID array on my ASUS Sabertooth Z97 Mark 2 MB (updated the BIOS and Intel's RST drivers), I can't get past the "Copying Windows Files" in the install mode. No little dots following the words, it just gets stuck. I made sure the MCT was using EFI Windows install. I just can't get Win 10 to load on the Mushkin SSD's in RAID 0. I deleted the array and tried again, but to no avail. I then went back to my Win 7 Pro flash drive and the OS loaded up without a hitch. So, the question remains is this, is there something about loading Win 10 on a RAID 0 array that I'm not aware of? I know some will say why a SSD RAID 0 array to begin with? I'm addicted to speed and it was working very well in its previous state, but ever since the AU, it just plain didn't behave properly. Now I can't figure out how to get Win 10 back on my SSDs (RAID 0).

Any insights would be helpful.