X

    Subscribe to New Ads!

    Receive weekly ads in your inbox!



Results 1 to 13 of 13

Thread: Corsair H60: cracks in the pipes..

  1. #1
    Registered User
    Join Date
    Sep 2013
    Posts
    4

    Corsair H60: cracks in the pipes..

    today I was upgrading the CPU of my home-server and I discovered that:





    should I worry?

  2. #2
    Administrator
    Join Date
    Nov 2007
    Location
    Stockton, CA
    Posts
    3,554
    hmmm... I would say... Not Good !

    RMA ?

  3. #3
    Xtreme Owner Charles Wirth's Avatar
    Join Date
    Jun 2002
    Location
    Las Vegas
    Posts
    12,373
    That looks to be the clamps were rubber straps, put new metal ones on if it is out of warranty.
    Intel 9990XE @ 5.1Ghz
    ASUS Rampage VI Extreme Omega
    GTX 2080 ti Galax Hall of Fame
    64GB Galax Hall of Fame
    Intel Optane
    Platimax 1245W

    Intel 3175X
    Asus Dominus Extreme
    GRX 1080ti Galax Hall of Fame
    96GB Patriot Steel
    Intel Optane 900P RAID

  4. #4
    Xtremely High Voltage Sparky's Avatar
    Join Date
    Mar 2006
    Location
    Ohio, USA
    Posts
    16,048
    Agreed. Those aren't the tubes themselves but the "clamps" (if you can call a stiff rubber ring a clamp). The tubes themselves look fine. I'd just get some standard clamps and put them on there in their place instead. No need to take the tubes off or anything like that.

    How old?
    The Cardboard Master
    Crunch with us, the XS WCG team
    Intel Core i7 2600k @ 4.5GHz, 16GB DDR3-1600, Radeon 7950 @ 1000/1250, Win 10 Pro x64

  5. #5
    Xtreme Mentor
    Join Date
    Oct 2007
    Location
    USA
    Posts
    2,622
    Ohh how long you had it?

    Not surprised really, it's a very old first iteration of a C WC setup. They probably didn't expect that. All about what the cheap manu used to keep the C folks happy. Made in etc country, questionable builds. Glad yours lasted so long. Most we see here lasts a few months, pump died etc. Consider yourself lucky.

    I bet you're past the warranty period, if not, post on 10 forums including the C forums and when you send in your RMA etc, link to every post you made.

    Inform folks about this big time, you'll get things worked out.

    Spend a week posting, building replies from the posts before looking for C input.

    You go cheap, you get stuff like this....................
    All stock for now, no need for more, but it's gonna be soon methinks.
    Giga Xtreme 58 mobo i7 965 ES D0 step Corsair 1600 6 gig
    SLI GTX470 EVGA
    EK HF nickle blue top CPU block (free from Eddie)
    Koolance 470 waterblocks
    One big loop, two 120x3 rads. Pa 120.3 and XSPC RX 120x3. Swiftech 35x pump with V2 restop. GT AP15 fans.
    Banchetto Tech Station
    120 GB SSD, and a few other drives.
    1000W UltraX3 PSU, 900 watt (1500VA UPS
    23.999" Acer GD235hz and 24" Acer H243H

  6. #6
    Xtremely High Voltage Sparky's Avatar
    Join Date
    Mar 2006
    Location
    Ohio, USA
    Posts
    16,048
    Quote Originally Posted by Conumdrum View Post
    Ohh how long you had it?

    Not surprised really, it's a very old first iteration of a C WC setup. They probably didn't expect that. All about what the cheap manu used to keep the C folks happy. Made in etc country, questionable builds. Glad yours lasted so long. Most we see here lasts a few months, pump died etc. Consider yourself lucky.

    I bet you're past the warranty period, if not, post on 10 forums including the C forums and when you send in your RMA etc, link to every post you made.

    Inform folks about this big time, you'll get things worked out.

    Spend a week posting, building replies from the posts before looking for C input.


    You go cheap, you get stuff like this....................
    Do what? Why not just go straight to manufacturer if it is under warranty and have them take care of it? If it is under warranty and they don't want to do anything about it then yeah get the word out, but other than that why try causing trouble? No reason for that, at all. Geez man
    The Cardboard Master
    Crunch with us, the XS WCG team
    Intel Core i7 2600k @ 4.5GHz, 16GB DDR3-1600, Radeon 7950 @ 1000/1250, Win 10 Pro x64

  7. #7
    The perils of poorly designed H2O coolers...

  8. #8
    Registered User
    Join Date
    Jan 2010
    Location
    B-region
    Posts
    35
    well, if it's not under warranty, put some clamps over it and call it a day! I'd add some duct tape, for ghetto looks

  9. #9
    Xtreme Addict
    Join Date
    Dec 2007
    Location
    Texas
    Posts
    1,789
    Just peel the old ones off and use small zipties in its place
    Sandy Bridge 2500k @ 4.5ghz 1.28v | MSI p67a-gd65 B3 Mobo | Samsung ddr3 8gb |
    Swiftech apogee drive II | Coolgate 120| GTX660ti w/heat killer gpu x| Seasonic x650 PSU

    QX9650 @ 4ghz | P5K-E/WIFI-AP Mobo | Hyperx ddr2 1066 4gb | EVGA GTX560ti 448 core FTW @ 900mhz | OCZ 700w Modular PSU |
    DD MC-TDX CPU block | DD Maze5 GPU block | Black Ice Xtreme II 240 Rad | Laing D5 Pump

  10. #10
    Uber Raid King
    Join Date
    Aug 2009
    Location
    Wichita, Ks
    Posts
    3,888
    How long have you had it?
    "Lurking" Since 1977


    Jesus Saves, God Backs-Up
    *I come to the news section to ban people, not read complaints.*-[XC]Gomeler
    Don't believe Squish, his hardware does control him!

  11. #11
    Xtreme Member
    Join Date
    Apr 2011
    Location
    Alberta Canada
    Posts
    288
    Last edited by solofly; 09-07-2013 at 11:11 AM.
    My toys...
    Asus X79 Deluxe | i7 4820K | Koolance CPU-380I w/Triple Rad/Swiftech Pump | RipjawsX 16GB 1866MHz | eVGA GTX 780 TRI-SLI | X-Fi Surround 5.1 Pro USB | Intel 530 120GB *2 RAID 0, Intel 510 250GB, Samsung 840 Pro 120GB, Samsung 840 500GB, Kingston V300 240GB | Corsair AX1200i | In Win D-Frame Orange | Win 8.1 Pro 64
    Asus Sabertooth Z77 | i7 3770K | NH-C12P SE14 | Vengeance 32GB LP | eVGA GT 240 | X-Fi Titanium Fatality | LSI SAS 9211-4i | Intel 330 120GB, Seagate 500GB *2, Samsung 200GB, WD 320GB *4 RAID 10, 500GB, Raptor 74GB | Antec TPQ-1200W | Corsair 650D | Win 8.1 Pro 64
    Asus Sabertooth P67 | i7 2600K | NH-U12P SE2 | Vengeance Pro 16GB 1866MHz | eVGA GTX 680 | Sound via HDMI | Intel 330 60GB, Samsung 840 Pro 120GB, WD VRaptor 300GB, 150GB *2 | Antec HCG-750W | Lian Li PC-60FNWB | Win 8.1 Pro 64
    Asus P8H77-M/CSM | i3 3220 | Shuriken | Vengeance 16GB LP | eVGA GT 610 | Sound Blaster Play | Hauppauge WinTV-HVR-1600 & HD PVR | Asus PCE-AC66 | Kingston V100 128GB, WD 1GB, 500GB, Seagate 2TB | Enermax Liberty 500W | Fractal Design Core 1000 | Win 8 Pro 64 w/Media Center
    Asus P8H77-M/CSM | i3 3220T | Hyper 212 Evo | Vengeance 8GB | eVGA 210 | Hauppauge WinTV-PVR-250 | Intel 330 60GB, WD 750GB, 250GB | Enermax Liberty 500W | Antec 300 | Win 7 Premium 32

    Axial SCX10 2012 Jeep Wrangler Unlimited Rubicon Modified

  12. #12
    Registered User
    Join Date
    Sep 2013
    Posts
    4
    Hi, thanks to all for answers.

    Today I showed the pictures to the responsible of RMA etc. in the shop where I bought the H60 and he told me I can have a replacement unit.
    As for me I will ask a cash-back or a coupon because I don't want to take any risk or simply think about "how long my corsair watercooling will work?" (even after the assurances by the corsair guy in the forum linked by solofly)

    P.S. my H60 was bought the 16th of february 2013, so less than 7 months ago..

  13. #13
    Xtreme Mentor
    Join Date
    Oct 2007
    Location
    USA
    Posts
    2,622
    Wow! Only 7 months! That's not good.
    All stock for now, no need for more, but it's gonna be soon methinks.
    Giga Xtreme 58 mobo i7 965 ES D0 step Corsair 1600 6 gig
    SLI GTX470 EVGA
    EK HF nickle blue top CPU block (free from Eddie)
    Koolance 470 waterblocks
    One big loop, two 120x3 rads. Pa 120.3 and XSPC RX 120x3. Swiftech 35x pump with V2 restop. GT AP15 fans.
    Banchetto Tech Station
    120 GB SSD, and a few other drives.
    1000W UltraX3 PSU, 900 watt (1500VA UPS
    23.999" Acer GD235hz and 24" Acer H243H

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •