I'll post this here also as under the Sabertooth thread.
I ordred this MB and dumb me a i7 2600. No K.

Its working fine, and i have OC it a bit. But there is a slight problem where the multiplier dont go up to x42 as i have in UEFI bios in windows & CPU-Z when under load. It goes to x39 and is rocksollid there. (tested about 7hrs) It gives a nice OC of 600, but from what i have in BIOS it should be 4.3+. aka 900 OC.

I used the auto OC function first and it set BLK to 103 and x42 turbo multiplier.

Anyone got and idea to why this happens, and it doesnt go to max multiplier underload in Windows?

There is also another part of this. I tried to set the BLK to 100 again and then try. The multiplier was then 40 of the bat in windows. And during a quick realtemp test at diffrent loads it fluxed from x39 to x41. But again not hitting x42.

I also tried only running 1 thread of test to see if it hit x42 but nothing diffrent on both BLK settings.

Ill add a pic from testing @103 and x42 in bios. Showing x39 in CPU-Z. (have gotten Realtemp btw, i know asus thing aint most accurat)

Attachment 117587

C1 on
C3 off
C6 off Speedstep on
(have tried everything off also, but no diffrence)

Any tip or help would be much helpfull!