Swiftech
Results 1 to 2 of 2

Thread: How To: Fix SecuLauncher: Failed to start application [2000] GTAIV PC Error.

  1. #1
    Xtreme Member itslogz's Avatar
    Join Date
    Jun 2007
    Location
    Winston-Salem, North Carolina
    Posts
    121

    Arrow How To: Fix SecuLauncher: Failed to start application [2000] GTAIV PC Error.

    GTAIV Was working fine on my 32-Bit XP harddrive, but once I tryed 64-Bit, all hell broke loose. So if you're getting the error "Seculauncher: Failed to start application [2000], this may help you.

    Step 1: Install GTAIV and get the error stated above.

    Step 2: Navigate to Control panel > Add/Remove Programs.

    Step 3: Locate Microsoft Visual C++ 2005 Redistributable, more importantly, one's that say something with x64 on end. Apparently this game runs on 32-bit? Im not completely sure, but 32-bit installer comes in the downloaded package once GTAIV is installed.

    Step 4: Uninstall any Visual C++ 2005 Redistributable items listed in Add/Remove programs.

    Step 5: Navigate to the GTAIV main folder, and locate the installers folder. (In my case its Program files > Steam > Steamapps >Common > Grand theft auto iv > installers. People using a disk it would be to right click on your DVD/CD drive in My computer, click explore, and find the folder named "Redistributable"

    Step 6: Find "vcredist_x86.exe"

    Step 7: Run this installer, complete the installation.

    Step 8: Check Add/Remove programs to see that the new 2005 C++ was installed.

    Step 9: Attempt to load GTAIV once more, through Social club Play button. This is as far as I got before I got a new error, the above got rid of my seculaunch error though.

    Step 10: If you're receiving a new error titled "GTAIV FATAL ERROR: RMN40", continue these steps, if not, play the game (Hopefully this worked for you, I could NOT find a solution until I tryed this reccomended by "theunknownsd" on gtaforums.com. He was the one who I found the above solution from, but I figured I would re-do these steps and post them as many places as I could to help other people in the same place I was.

    Step 11: If you did get the "GTAIV FATAL ERROR: RMN40" after doing the above, right click on LaunchGTAIV.exe in the main GTAIV folder, and GTAIV.exe in the main GTAIV folder, and make sure that under the Compatibility tab that "run this program in compatibility mode for:" is not checked on all of the launchers. At this point, I got a NEW error once I solved that one, so if you had the RMN40 error, and unchecking compatibility mode fixed it, you may have now received the error "GTAIV FATAL ERROR: WS10", if so continue reading.

    Step 12: If you got the "GTAIV FATAL ERROR: WS10", check Add/Remove programs to make sure you have "Microsoft Games for Windows Live Redistributable installed, if you do and you still get the error, uninstall the program at this time.

    Step 13: Navigate to Program files > Steam > Steamapps >Common > Grand theft auto iv > installers >xliveredist.msi (Or the redistributable folder when exploring the CD for people using a CD.

    Step 14: WS10 error supposibly has to do with windows live, so you want to uninstall and reinstall if you already had it, or install it from the folders in step 13 if you didnt have it at all. After uninstalling run xliveredist.msi (Or if your just now installing) and complete the setup.


    Step 15: If you still get the WS10 error, download the following GTAIV Patch (Normally downloaded through social club, but at the time it wouldnt let me login to social club, this way is probably faster anyway) http://files.filefront.com/GTAIV+PC+.../fileinfo.html

    Step 16: Unzip the GTAIV_PC_Patch folder, and run the Setup.exe

    Step 17: Hopefully now, when you launch GTA through social club, it will load up with no errors. In my case, all of the above got me up and going, there needs to be a hardfix patch for all this BS but I took the time to write this up since I was so mad over it.

    Hope this helps some people.
    Last edited by itslogz; 01-18-2009 at 03:16 AM.
    Q9650 L826A965 | 4.0Ghz 1.27v
    Gigabyte EP45-UD3P F7 Bios
    eVGA GTX 280
    CPU= D-Tek FuZion V2 / Laing D5 Basic / XSPC RX-240
    Corsair 2x2GB PC2-8500
    Corsair 1000HX
    AuzenTech X-Fi Prelude | Logitech Z-5500
    WD 250GB SE / WD 1TB Green
    Antec Nine Hundred

  2. #2
    Xtreme Member itslogz's Avatar
    Join Date
    Jun 2007
    Location
    Winston-Salem, North Carolina
    Posts
    121
    Finally fixed it myself after over a day of working on it. Did my own how:to guide edited the OP with it, hopefully itll help some people in the future.
    Q9650 L826A965 | 4.0Ghz 1.27v
    Gigabyte EP45-UD3P F7 Bios
    eVGA GTX 280
    CPU= D-Tek FuZion V2 / Laing D5 Basic / XSPC RX-240
    Corsair 2x2GB PC2-8500
    Corsair 1000HX
    AuzenTech X-Fi Prelude | Logitech Z-5500
    WD 250GB SE / WD 1TB Green
    Antec Nine Hundred

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •