MMM
Page 1 of 3 123 LastLast
Results 1 to 25 of 71

Thread: X48 BlackOps PSU Compatibility list

  1. #1
    Xtreme X.I.P.
    Join Date
    Nov 2002
    Location
    Shipai
    Posts
    34,647

    X48 BlackOps PSU Compatibility list

    Hey Guys,

    To make sure our Boards work with as many PSUs as possible and to help people who build a new system pick a PSU that is know to work well, please post what PSU your using (model no if possible) and let us know if its working fine or you have any issues that could be psu related, such as:
    - oc recovery issues, board getting stuck in an endless rebooting loop
    - posting issues, board doesnt post properly or at all
    - instability, board will shut down under load

    Endless rebooting loops can be caused by the psu taking a long time to discharge.
    If you turn off the psu, turn it on again and push the power button before the onboard LEDs on the motherboard have turned off, the board might end up in an endless rebooting loop or might not boot properly anymore. to fix this remove the bios battery and put it back after a few minutes.
    If you still experience problems please post as many details about the PSU your using or send me or lardarse a private message.


    Known to work:
    Antec Truepower Trio 650w
    Be Quiet Straightpower 650w
    Corsair HX520W
    Corsair 550W
    Corsair HX620W
    Corsair TX750W
    Corsair HX1000W
    Cooler Master Real Power M700
    Cooler Master 1000W
    Cooler Master Real Power M1000
    Cooler Master HX1000
    Cooler Master Real Power Pro 1250W
    Coolmax CUQ-1200B
    Dell 1000w from XPS-H2C
    Enermax EG465AX-VE(W)
    Enermax Liberty 500W
    Enermax MODU82+ 525w
    Enermax Modu82+ 625w
    Enermax Galaxy 1000W EGX1000EWL
    Enermax Revolution 1050W
    Etasis ET850
    HighPower 1000W Rock Solid
    OCZ EliteXStream 1000W
    PCPNC 750w
    PCPNC 850W
    PCPCN 850W SSI
    PCPCN 1000W
    PCPNC 1200w
    Seasonic 600W M12
    Seasonic 700W M12
    Silverstone Strider 600w
    Silverstone 650W
    Silverstone Zeus STZF75 750W
    Silverstone Zeus STZF85 850W
    Silverstone DA-1000
    Silverstone Olympia 1000W
    Silverstone OP 1000W
    Silverstone Strider 1000W (ST1000)
    Silverstone OP 1200W
    Silverstone Zeus ZM1200M 1200W
    Tagan tg430 EasyCon
    Tagan 900W
    Tagan BZ 1100W
    Tagan BZ 1300W
    Thermaltake Tough Power 750W
    Thermaltake Tough Power 850W
    Thermaltake Tough Power 1200W
    Ultra X3 1000W
    Ultra X3 1600W
    Zalman ZM1000-HP
    Zippy PSL6701 700W


    Might cause problems?
    Abit Modular 900W?
    Enermax 565W
    Enermax Galaxy DXX 1000W?
    OCZ GameXstream 700W


    confirmed compatibility issues:
    Enermax Galaxy DXX 720W - click here for details


    If you have several PSUs, it would be really cool if you could check them and boot a couple of times and enter bios and save etc, just to check if they work. this will helps us to find out if there are PSU related issues, and if there are, where they come from and how we can fix them.
    thanks a lot in advance!

    EDIT: list updated and sorted alphabeticaly
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated
    EDIT: list updated with test results
    Last edited by saaya; 02-06-2009 at 02:44 AM.

  2. #2
    Registered User
    Join Date
    Jun 2008
    Posts
    20
    I'm using the Enermax Galaxy 1000, EGX1000EWL. It's working like a charm for me and thats with everything in my case running off of it.
    QUADZILLA
    FOXCONN Blackops G28 Bios - Vista 64 Ultimate SP1
    Core 2 Extreme QX9650 @ 4.0 GHz - Apogee GTX Waterblock
    2 x HIS HD 3870X2's Crossfired - EK Waterblocks - 8.6 CCC
    Dominator DDR3-1800 (2x1GB) @ 1800 - 7-7-7-20-1T
    Enermax Galaxy 1000W
    2 x WD 320GB SATA II
    Plextor SATA DVD+-RW PX-810SA
    Blackops Sonar - Gigaworks S705 7.1 Surround Sound System
    HP LP3065 30" Flat Screen Monitor
    Custom UFO case - 4 W/C Loops - 4 D5 Pumps - 4 XPSC Res's - 4 PA Rad's

  3. #3
    Xtreme Member
    Join Date
    Sep 2005
    Location
    Dublin, Ireland
    Posts
    204
    Dell 1000w from XPS-H2C Works fine. (These are lovely PSU's you can get very cheap)

  4. #4
    Registered User
    Join Date
    Sep 2007
    Location
    Where mods are made and h/w dies
    Posts
    72
    Coolermaster realpower 1000w , has problem with oc recovery some times goes in an endless loop
    Out Of Specs -- Cyprus Department


  5. #5
    Turkey Man
    Join Date
    Mar 2005
    Location
    Jakarta (ex-Australia)
    Posts
    2,584
    Silverstone OP1000, sometimes endless boot loops but that is user caused

  6. #6
    Registered User
    Join Date
    Dec 2007
    Location
    Germany, Schleswig
    Posts
    19
    Tagan Piperock BZ 1100w, Be Quiet Straightpower 650w, Enermax MODU82+ 525w and Enermax EG465AX-VE(W) all doiing fine.

  7. #7
    Xtreme n00berclocker
    Join Date
    Mar 2006
    Location
    San Jose, CA
    Posts
    1,457
    Fine with my PCPower and Cooling 750w and both my silverstone 1200 and 650
    Quote Originally Posted by 3oh6
    damn you guys...am i in a three way and didn't know it again
    Quote Originally Posted by Brian y.
    Im exclusively benching ECS from this point forward

  8. #8
    Xtreme Member
    Join Date
    Nov 2007
    Location
    United Kingdom
    Posts
    252
    enermax galaxy 850. Im not sure the psu was causing my problem but were similar to as described above. my board was returned so when the replacement arrives ill post here if the issue continues.

  9. #9
    Xtreme Member
    Join Date
    Feb 2008
    Location
    Lewiston, ID USA
    Posts
    195
    Ultra X3 1000. Fine and dandy on my end.

  10. #10
    Xtreme Addict
    Join Date
    Mar 2008
    Location
    川崎市
    Posts
    2,076
    tried it with my other psu's,
    pcp&c 1kw, tt toughpower 750w, corsair 550W, Silverstone DA 750w all working fine as well.
    however, LardArse posted in other thread its only with some boards that the Issue exists, not all have it, so dont know how reliable the test is since I dont really know if my board is one of those that is picky on the psu.

  11. #11
    Xtreme Enthusiast
    Join Date
    Feb 2006
    Location
    Telford,west mids UK
    Posts
    724
    Thermaltake Tough Power 850w works ok for me.

  12. #12
    Xtreme Enthusiast
    Join Date
    Nov 2006
    Location
    Poland / Rypin
    Posts
    865
    tagan tg430 EasyCon is working good.

    what a shame

    all you guys have nice psu's and I with little tagan, only 430. my e-pennis: -1
    Last edited by FatAlbert; 06-27-2008 at 09:06 AM.
    Schedule of Live Extreme Overclocking - info Thread

    Quote Originally Posted by K404 View Post
    "My Backup is bigger than Your Backup"

  13. #13
    Admin
    Join Date
    Dec 2003
    Location
    Hillsboro, OR
    Posts
    5,275
    Zippy PSL6701 700W and Silverstone Zeus STZF85 850W are good to go.

  14. #14
    Xtreme Member
    Join Date
    Feb 2006
    Posts
    345
    Cooler Master 1000W works great.

    Abit Modular 900W would not boot Blackops consistently.

    QX9770@3.66Ghz 24/7 365
    790i STriker II Extreme Rock Solid Stable (finally)
    8GB Corsair XMB 1600Mhz DDR3
    MSI 280GTX OC 650/2300 in SLI
    300GB Velociraptor, 500GB Data
    4X Liteon Blu-ray Burner
    MMORPG
    Vista 64

  15. #15
    Xtreme Member
    Join Date
    Sep 2005
    Location
    Dublin, Ireland
    Posts
    204
    PcP&c 850 and 1k fine on mine too. Looking to see if I can check any others.

  16. #16
    Xtreme X.I.P.
    Join Date
    Nov 2002
    Location
    Shipai
    Posts
    34,647
    Quote Originally Posted by GTFouts View Post
    I'm using the Enermax Galaxy 1000, EGX1000EWL. It's working like a charm for me and thats with everything in my case running off of it.
    thanks a lot m8!
    Quote Originally Posted by MasterOfTheReal View Post
    Dell 1000w from XPS-H2C Works fine. (These are lovely PSU's you can get very cheap)
    thanks for the hint
    do you happen to know who builds those PSUs?

    Quote Originally Posted by yiancar View Post
    Coolermaster realpower 1000w , has problem with oc recovery some times goes in an endless loop
    when you run the same settings in bios and just keep rebooting and entering bios and hitting save and exit? or does it happen when you turn off the board and then turn it on again? or does it happen when you change stuff in bios and hence might be caused y pushing the hardware too high?

    Quote Originally Posted by T_M View Post
    Silverstone OP1000, sometimes endless boot loops but that is user caused
    wouldnt have expected anything lesser from you hehehe

    Quote Originally Posted by StellaNor View Post
    Tagan Piperock BZ 1100w, Be Quiet Straightpower 650w, Enermax MODU82+ 525w and Enermax EG465AX-VE(W) all doiing fine.
    thanks a lot!

    Quote Originally Posted by Cpt.Planet View Post
    Fine with my PCPower and Cooling 750w and both my silverstone 1200 and 650
    cool, thanks for checking jake!

    Quote Originally Posted by bustamove44 View Post
    enermax galaxy 850. Im not sure the psu was causing my problem but were similar to as described above. my board was returned so when the replacement arrives ill post here if the issue continues.
    thanks
    did you have endless reboot issues then? or did you rma the board because of some other problem?

    Quote Originally Posted by Broken View Post
    Ultra X3 1000. Fine and dandy on my end.
    cheers is that the name of the mfc? ultra?

    Quote Originally Posted by naokaji View Post
    tried it with my other psu's,
    pcp&c 1kw, tt toughpower 750w, corsair 550W, Silverstone DA 750w all working fine as well.
    however, LardArse posted in other thread its only with some boards that the Issue exists, not all have it, so dont know how reliable the test is since I dont really know if my board is one of those that is picky on the psu.
    thanks for checking!
    well we didnt hear about those oc recovery loop problems until recently, so sham is supecting it might be a problem with the latest batch of boards... but its hard to tell... the infos you guys posted here seems to indicate that it might be psu related... so maybe the new batch for some reason doesnt work well with some psus...

    Quote Originally Posted by clone38 View Post
    Thermaltake Tough Power 850w works ok for me.
    thanks

    Quote Originally Posted by Fatalbert View Post
    tagan tg430 EasyCon is working good.

    what a shame

    all you guys have nice psu's and I with little tagan, only 430. my e-pennis: -1
    time to look for one of those DELL 1000W psus then

    Quote Originally Posted by Gautam View Post
    Zippy PSL6701 700W and Silverstone Zeus STZF85 850W are good to go.
    thanks!

    Quote Originally Posted by ceevee View Post
    Cooler Master 1000W works great.

    Abit Modular 900W would not boot Blackops consistently.
    hmmmm but it does work with other boards?
    could you post the detailled specs please?

    Quote Originally Posted by MasterOfTheReal View Post
    PcP&c 850 and 1k fine on mine too. Looking to see if I can check any others.
    thanks a lot man

  17. #17
    Xtreme Member
    Join Date
    Nov 2007
    Location
    United Kingdom
    Posts
    252
    I think it was some other problem saaya, I just received my replacement. I havent tried the galaxy yet but my tagan 900w psu is fine. the board is a lot better responding than the first so I assume it was a faulty board anyway.

  18. #18
    Xtreme X.I.P.
    Join Date
    Nov 2002
    Location
    Shipai
    Posts
    34,647
    Quote Originally Posted by bustamove44 View Post
    I think it was some other problem saaya, I just received my replacement. I havent tried the galaxy yet but my tagan 900w psu is fine. the board is a lot better responding than the first so I assume it was a faulty board anyway.
    hmmm thanks for getting back to me
    what exaclty were the problems you had with the first board?
    what bios were you running?

  19. #19
    Registered User
    Join Date
    Apr 2006
    Posts
    81
    Silverstone Strider 1000W (model number: ST1000) works fine no issues here.

  20. #20
    Xtreme X.I.P.
    Join Date
    Nov 2002
    Location
    Shipai
    Posts
    34,647
    thanks!

  21. #21
    Registered User
    Join Date
    Jan 2008
    Posts
    15

    Question

    Quote Originally Posted by bustamove44 View Post
    I think it was some other problem saaya, I just received my replacement. I havent tried the galaxy yet but my tagan 900w psu is fine. the board is a lot better responding than the first so I assume it was a faulty board anyway.
    Hi. I have the Enermax Galaxy 850W (DXX version). Is your psu exactly the same model?

    Any news about this psu with the new BlackOps? Eventually, please can you try it?

  22. #22
    Xtreme Enthusiast
    Join Date
    Aug 2005
    Location
    Romania, Transylvania crazyp.ro
    Posts
    649
    Silverstone Zeus ZM1200M 1200W
    Enermax Liberty 500W

    Both works without any issues and problems.
    -------------------------------------------------------------------------------------------------------------------------------


    3Dmark2006 Score Calculator
    ---------------------------

    "Frequency Unlimit -Enabled'' by DFI

  23. #23
    Xtreme X.I.P.
    Join Date
    Nov 2002
    Location
    Shipai
    Posts
    34,647
    Quote Originally Posted by Rambo87 View Post
    Hi. I have the Enermax Galaxy 850W (DXX version). Is your psu exactly the same model?

    Any news about this psu with the new BlackOps? Eventually, please can you try it?
    welcome to XtremeSystems rambo

    thanks m3kk

  24. #24
    Registered User
    Join Date
    Jan 2008
    Posts
    15
    Quote Originally Posted by saaya View Post
    welcome to XtremeSystems rambo
    Thank you very much... Finally I wrote in this forum

    Anyone has Enermax Galaxy 850W DXX with Foxconn BlackOps...

  25. #25
    OCTeamDenmark Founder Nosfer@tu's Avatar
    Join Date
    May 2004
    Location
    Denmark, Copenhagen
    Posts
    2,368
    Etasis ET850 works fine.

    The enermax 750 is the infinity model!
    Dont know about others.

    Will test Antec 1000 Watt and NorthQ1000 Watt 2.
    Former owner of OCTeamDenmark.com
    MSI MOTHERBOARD!!!!!!

    Linkedin


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •