just wait for non-extreme version