PDA

View Full Version : MacIntel :OSXx86 running native:



JAWS
10-11-2005, 07:14 PM
I know this is old news to most but it’s something I’ve been messing around with lately. basically running OSXx86 native with no emulation, PearPC, or VMware. I’ve never used anything Mac related, so consider me a Mac noob. It took me a long time to get everything working, but all hardware is functional.

LAN, printer, ps/2, all working. (after a lot of long nights)


Anyways I’ll post more pics, when I learn how. Lol

Can someone with a G5 run a complete xBench benchmark? and post the results for me?
Thanks

http://img15.imageshack.us/img15/1415/x863qw.jpg

ps gotta love the "about this mac" in that pic. AMD64

Corbu'
10-12-2005, 02:46 AM
How did you install MAC OS X on an AMD CPU? I thought Apple would prevent this with a special kind of chip on the mainboard, if the chip is not present > No install. No more Windows on my “business” laptop, no more viruses, no more spyware. Could this be true? :slobber: I am very interested in finding out more details… :clap:

s e t h
10-12-2005, 04:16 AM
the security feature was cracked very quickly.
a mac/intel developer copy of osx has been floating about for a while now.
the thread i started on it here was locked in a matter of hours
there are already entire forums dedicated to all the issues encountered while doing this install

do a bit of searching and then about 1.3gb of downloading.
follow that up with many hours of studying/tweaking/banging your head and you should be able to get osx running very nicely on any current athlon64/sse3 rig :)

MeltedDuron
10-12-2005, 07:49 AM
what about AXP? :p: i could really use this on one of my rigs, xp suxx, got a guide?

JAWS
10-12-2005, 08:32 AM
what about AXP? :p: i could really use this on one of my rigs, xp suxx, got a guide?

you need SSE2 or better. not sure about AXP?

MeltedDuron
10-12-2005, 08:38 AM
damn, only SSE1, oh well i'm gonna get the dothan back up, build a nice A64 ig, and a 2ghz P4 rig soon... Still, is there an install guide? I have the ISO on here but idk what to do with it.

Corbu'
10-12-2005, 08:44 AM
MeltedDuron you have a PM !

MeltedDuron
10-12-2005, 08:46 AM
thanks, reading now.... You now officially F*cking rule!

Obi
10-13-2005, 01:29 AM
Ive got a mate who's had OSX Tiger running on his
AMD Turion MT-30 for over a month.... says is great!

Pitty he's not much of a MAC guy though...
If you likeI can tell you where to get all the right files and guides if you like. There is a nice torrent going around from what I hear:)


edit.... apparentally I cant let this info slip... silly me :nono:

Vapor
10-13-2005, 02:23 AM
Unfortunately Obi, info like that cannot be shared on XS, please do not post it.

There are many nice guides on the net though with DETAILED info, those may *not* be posted either, even to help people with the dev kits through the process of making it native.

s e t h
10-13-2005, 03:54 AM
http://www.xtremesystems.org/forums/showthread.php?t=71692

pancake
10-13-2005, 08:47 AM
i had it running on this machine with 2.4b p4 , it wouldnt detect my modem though so no net , hardware accelerated gfx dont work unless you have the exact same mobo the dev kits use , but apart from that it ran so smooth

JAWS
10-13-2005, 09:07 AM
unless you have the exact same mobo the dev kits use

http://www.newegg.com/Product/Product.asp?Item=N82E16813157075

it will be here Friday. and its pretty close to the one I used.

pancake, did you try a pci card or onboard LAN?

after giving up on the nforce onboard I found this old card in my bag of parts: works perfect

3com EtherLink XL PCI 3C900B-TPO REV. A

On the Chip: Parallel Tasking II Lucent 40-04564

Vapor
10-13-2005, 09:09 AM
I'm pretty sure it works with nV cards pretty well, sse3 is also a big bonus for the gui I've heard. Anyway, I should have it up and running this weekend if I get the time....I love OSX and I love my X2, now they can love each other.:buddies:

JAWS
10-13-2005, 02:50 PM
I'm pretty sure it works with nV cards pretty well, sse3 is also a big bonus for the gui I've heard. Anyway, I should have it up and running this weekend if I get the time....I love OSX and I love my X2, now they can love each other.:buddies:


very cool vapor! let me know how it goes ;)

Vapor
10-13-2005, 03:08 PM
I'll be sure to post all I can when it's up and running ;)

Not sure if I'll be able to tell it apart from my XP install visually though--it looks damn near identical to OSX. :banana:

JAWS
10-13-2005, 03:10 PM
Just got home to a pleasant surprise. don't laugh at the hardware, because now the system will support Quartz Extreme and coregraphics . (no other video card is supported) plus much, much more but I don't know the mac terms......lol



http://img7.imageshack.us/img7/7494/dscf09135oc.jpg

http://img7.imageshack.us/img7/6206/dscf09111hh.jpg

Vapor
10-13-2005, 03:13 PM
That's pretty sick mate....can't wait for results.

Vapor
10-13-2005, 06:30 PM
This thread is for those with DEV kits....there should be no worry about IP reporting.

JAWS
10-13-2005, 07:09 PM
Oh just a little note about the stuff you are doing.( raises flag that says arrrrrrrg. torrents. )


no worry, as vapor said some of us had the dev kit. also I will not link to any x86 sites; that link to the other sites. ;)

WesM63
10-13-2005, 08:01 PM
ok... i'm interested.. can someone send me some info.. PM Please!

JAWS
10-15-2005, 04:41 PM
ok... I’m interested.. can someone send me some info.. PM Please!

I'll send you a pm in a few


Well I put together my MacIntel last night with zero problems. the hardware components I used were nothing special, except for the mobo and cpu.

Confirmed Quartz Extreme and Core Image are supported so everything looks perfect. I must say I am very impressed how good OSX looks and how well it works.

http://img405.imageshack.us/img405/2791/desktop11wb.jpg

Vapor
10-15-2005, 06:30 PM
Yeah, I'm still having problems running mine natively, it doesn't like booting from the non-primary drive and I can't partition my primary drive for some reason :confused:

Looking good there JAWS :D

pokipoki
10-19-2005, 08:57 AM
Will someone kindly PM me some info. Would love to get it running on dual-Xeons (Nocona). Thanks :)

tonyl
10-20-2005, 05:11 PM
Will someone kindly PM me some info. Would love to get it running on dual-Xeons (Nocona). Thanks :)

I got it work on my Dell WS 670, E7525 chipset is supported, everything working, very fast.

JAWS
10-21-2005, 01:40 PM
I got it work on my Dell WS 670, E7525 chipset is supported, everything working, very fast.


cool! have you run xbench yet? if you do, please post the results. :)

Vapor
10-22-2005, 05:12 PM
For the protection of this thread....can all requests for PMs please be done in PM.

This thread is to help those fortunate enough who have Dev kits and legal rights to the early builds of OSXx86....not for everybody and their brother (who don't have the Dev kits) to sign up for JAWS's PM on how to make 'any' install native.

i found nemo
10-26-2005, 09:14 AM
now we can bench amd's vs g5!!!!!!

Vapor
10-26-2005, 09:15 AM
Not quite yet.....the Dev kits aren't full speed for x86 yet and patches are slow to come.

setyotomo
10-27-2005, 11:30 AM
btw JAWS.. in your #1 post.. what mobo are you using? sorry if i asked again..(allready ask via PM)

did you allready run xBench yet?

JAWS
10-27-2005, 02:22 PM
btw JAWS.. in your #1 post.. what mobo are you using? sorry if i asked again..(allready ask via PM)

did you allready run xBench yet?


hey setyotomo! in the first post I was using a DFI LANPARTY UT nF3 250Gb and actually had a very nice xbench for that setup. I switched to http://www.newegg.com/Product/Product.asp?Item=N82E16813157075 this mobo is cheap and supports everything from video to lan. look through this thread for the pics. I'll post more xbench results later.

setyotomo
10-29-2005, 12:46 PM
yes that definetly a cheap mobo for sure... :D , and yes i will wait for your xbench result.. this is very very interesting.. :D

good luck btw ;)

JAWS
11-02-2005, 07:11 PM
yes that definetly a cheap mobo for sure... :D , and yes i will wait for your xbench result.. this is very very interesting.. :D

good luck btw ;)

here is xbench results: pre-update

I'll post DFI xbench and post-update in a few....

JAWS
11-02-2005, 07:38 PM
xbench post update score: 47.09 :)

the_new_guy
11-06-2005, 06:39 AM
the scores are depressing, my emac get 150+
the results are bad coz xbench is running emulated, its not a x86 app

JAWS
11-06-2005, 08:24 AM
the scores are depressing, my emac get 150+
the results are bad coz xbench is running emulated, its not a x86 app


lol I agree!

the MacIntel looks great, but isn't as fast. my score was upper 90s with AMD64.

[XC] moddolicous
11-06-2005, 11:23 AM
Well, right now I'm on an Imac (1.42ghz w/ 512mb ram) here at the mall. Just thought u guys would like to know. The keyboard is really cramped, though.