PDA

View Full Version : Mixing it up - raid



tived
09-22-2012, 06:46 AM
Hi guys,

been playing around with my new toy, the Areca 1882ix 4GB cache & BBU with 8x Intel 520 120GB and 8x Samsung 830.

Trying to work out what will give me the best performance but i don't think i am getting there atleast i am no where near what i see Computurd do, the master himself. I had expectations of reaching well into 3GB/s with either 8 disks but i have only reached that with the Intel using ATTO
130207
from memory this is RAID-0 default settings on the Areca 1882ix

but that's not so when i run ASU
130210
pass-through and stripped in Windows 7 x64 pro

what i seem to find is that the read's are plateau'ing out at around 2.6GB/s i don't know if that is a limitation of my PCIe x8 and my chipset on the EVGA SR-2, i remember ACE-NZ had some problems a few years ago. Am I not using the right drivers or is this just the best i can do??

Now, just for fun, i thought that i would make two stripe sets with each brand and then stripe them in windows.... but MIXING IT UP isn't doing me any favors unfortunately
130208130209
here i created the two 8R0 on the controller and then stripped them in Windows

Someone suggested to me that i should use my two IBM M1015 fill them with SSD's and create a stripe set on each and then stripe them in Windows RAID-00 across two controllers, but currently i have one in use in another box where I am trying to recover an OLD WD ShareSpace (guys don't ever waste your money on that! WD SS)

well thats it guys, that was my saturdays night fun ;-)

Henrik

tived
09-22-2012, 06:51 AM
just adding ASU

130214

2 arrays on the same controller stripped in Windows

8x Intel 520 120GB RAID-0
8x Samsung 830 128GB RAID-0

Areca 1882ix 4Gb cache with BBU

on EVGA SR-2 x5650 default 48GB ram

thanks

Henrik

Nizzen
09-23-2012, 12:09 PM
I have problems with EVGA and sas controllers as well.. The pci-e lanes is just wierd when I have 2x gtx 680 + Areca 1880ix-24 + LSI 9207-8i.

But with Gigabyte x79 ud7, it looks better.

ASSSD with only four of my 12 Plextor m3p 128gb @ LSI 9207:

http://i413.photobucket.com/albums/pp219/Nizzen/ASSSDLSI4xR0softsrvR2_zps9b0f5d8d.png
http://i413.photobucket.com/albums/pp219/Nizzen/ATTOLSI4xR0softsrvR2_zps1d6a8302.png
And 8x R0 :D
http://i413.photobucket.com/albums/pp219/Nizzen/ASSSDLSI8xR0softsrvR2_zps202df92b.png
http://i413.photobucket.com/albums/pp219/Nizzen/ATTOLSI8xR0softsrvR2_zpsad29e1d4.png

4xR0 Areca1880ix 4gb cache @ gigabyte x79 ud7: 2x 680 + lsi + areca... All slots filed up.
http://i413.photobucket.com/albums/pp219/Nizzen/AsssdAreca4xr0_zps6d24ed40.png
http://i413.photobucket.com/albums/pp219/Nizzen/ATTOAreca4xR0srvR2_zps7c256aed.png
I do not know what Evga is doing, but they can not do the same as Gigabyte!

If someone wants pci-e x 3.0 working with GTX 680 SLI and lsi pci-e 3.0 controllers, Gigabyte x79 UD7 is the :banana::banana::banana::banana: ;)
With Evga x79 FTW I can not get pci-e 3.0 working on both 680 cards.

tived
09-23-2012, 04:28 PM
there is certainly something wrong with the Evga i am getting really poor results as can be seen on the several post that i have made

thanks very much for sharing this Nizzen

Henrik

tived
09-24-2012, 04:14 AM
those figurs are certainly much more what I am looking for.

Nizzen, do you still have the EVGA SR-2? Do you think its hardware issue or a driver issue, have you tried different PCIe slots? Only asking to save myself the hassel to do so, but will investigate it if you haven't

I have just made a fresh install of windows 7 and the results from my benchmarks were not worth posting - 8 or 12 drive array were as slow or slower then one drive by itself. I am booting off the 1882ix with the 8x Samsung in RAID-0 and then i have another array with my 12x Intel 520's and its just crap

what drivers are you using? i am just wondering if I have done something wrong or have not installed something i should have????

sorry for all the questions.... but its so frustrating

Henrik

joelz
11-14-2012, 04:27 PM
Since this site is rooted in extreme systems, I don't feel out of place sharing what I found regarding fast RAID volumes with SATA 3 SSD's.

1) You are likely hitting the PCIe v2 limits, as I did. I validated this by using a PCIe bandwidth benchmark from NVIDIA, its called bandwidthTest.exe and its part of their SDK.

2) I worked around this limitation problem by installing 3 different LSI 9260 controllers. Then attached 2 Vertex 3 drives on each one. Then striped them in the HW RAID. In windows, the 3 volumes were striped. Each volume is 64k stripe (since that is what windows uses).
Only 2 Vertex 3's will max out the LSI, adding 3 was leaving IO on the table.

3) Atto maxes out just under 5 GB/s and hits a bug. The problem is the calculations are wrong. I proved this by rolling my own drive IO measurement tool (since the Resource Monitor in Windows hangs at high IO). I contacted support and they are not fixing it, they were point blank about that. While running Atto to provide IO transfers and measuring the transfer rate, the GB/s measurement was north of 6GB/s. :D Finally ;)

Another note about using Atto is we need to use a size greater (Total Length value) than the cache size, otherwise its all cached hits (per Atto support).

Last note on Atto, using a higher Queue Depth allowed the drives to max out. The default Queue Depth setting left the drives well under 100% utilization.

Please don't ask why I went through the trouble to break through the wall of one HW RAID controller with super fast SSD's, because I don't know what is wrong with me :)

coo-coo-clocker
11-17-2012, 05:25 AM
Since this site is rooted in extreme systems, I don't feel out of place sharing what I found regarding fast RAID volumes with SATA 3 SSD's.
. . .
Please don't ask why I went through the trouble to break through the wall of one HW RAID controller with super fast SSD's, because I don't know what is wrong with me :)

Hah! Nothing wrong with you man - you're just Xtreme!

Nizzen
11-17-2012, 10:20 AM
www.xtremesystems.org/forums/showthread.php?272827-2x-Areca-1880-5.1GB-s-seq-279k-IOPS-!!&p=4895039&viewfull=1#post4895039

Old, but still good.
Picture, or it did not happened