View Full Version : Snipers dont work in GB 890GPA-UD3H

06-07-2011, 08:15 AM
I Bought the F3-12800CL9D-8GBSR wich has listed "AMD 890 Series" support.
My boaard is rev 2.1 and run the newest normal bios (not the AM3+ support bios), FF.
I have resetted bios, tried 1333mhz, tried both sticks alone, but with this ram the board just refuses to boot.

Any ideas?

06-07-2011, 08:27 AM
Try another kit to see if it works better. Should have no problem at all with that motherboard. Do you have other DDR3 memory you can try to make sure it is not a problem with the motherboard?

Thank you

06-07-2011, 08:54 AM
I have 3 kits here now.
The G.skill kit.

Patriot Gaming Sector 5 2x 4GB kit (1600 CL9) There seemes to be some subtimings or something (wich i cant se and change) that get changed when switching from auto to manual with this kit that isnt compitable. When i switch form auto to manual i get overclocking failed, even if i match all the auto settings. This kit also auto to CL11 with 2t command rate so its uber slow.
This kit behaves exactly the same in my previous 880GMA UD2H...
Kingston hyperX Blu. This kit works @ atleast 1768 8.9.7, but this kit is only 2x 2GB so its not enough for me

06-07-2011, 11:05 AM
You said DDR3-1333 was a problem too, so send them in for RMA and try a new kit.

Thank you

06-07-2011, 12:46 PM
They wont even work as a single stick (yes i tried both) @ 1066

Sounds weird that they both are faulty....