PDA

View Full Version : MacPro Hard Disk Sleep Issue Resolved



TheMysticWizard
09-13-2007, 09:14 PM
Okay, so here was the situation.

My Girlfriend recently purchased a MacPro with the 2.66 ghz Xeons and the ATI x1900xt. I took the liberty to go ahead and tweak it out a bit, adding 3 more 250gb Hard Drives, 3 more pairs of 512's (for a total of 8-512's (4gb) of ram, and Accelero x2 cooler for the x1900xt. I set 3 of the 250gb drives in RAID 0 via Mac OS, and installed OS X on those (she's a big OS X fan, so she will be using that the most) and left the final 250gb drive as a dedicated Windows XP partition, which will be used by me, and for gaming.

Needless to say, the system runs great. It really has some processing power, however I will not debate the issue of Memory Bandwidth.

On to the problem, The hard disks kept spinning down in Mac OS X and causing the whole system to stall for a few seconds when you went to do something. I went through the energy saving settings, unchecked the box telling it to put the disks to sleep. Should have been solved right?

Wrong. The hard disks kept going to sleep whenever you wern't doing something. So I searched the net for answers and stumbled upon something...

In terminal I ran "pmset -g" and it showed "disksleep --- 180"

I had to run a command in there, "pmset -a disksleep 0" to change it.

then I ran "pmset -g" again and now "disksleep --- 0"

and guess what. No more hard disk spin down. Worked great.

Hopefully this can be of help to someone if they run into the issue, as I didn't find the answer laid out like this, I had to play with it for a bit.

lowfat
09-14-2007, 08:20 AM
Try resetting the PRAM (hold command+option+p+r at startup till computer chimes twice)?

Also reset the SMC by unplugging everything from the computer including power cord for a minute.